Paquets Debian

De Disposition de clavier francophone et ergonomique bépo

Les paquets pour Debian et Ubuntu contenant la disposition fr-dvorak-bépo sont nommés xkb-data et libx11-data. Ils sont disponibles dans l'espace de téléchargement. Dans le détail, il s'agit des versions officielles disponibles sur les dépôts des distributions, complétées par la disposition fr-dvorak-bépo dans sa dernière version (actuellement, ils n'apportent que la lettre grecque morte qui n'a pas été acceptée par Xorg); ils possèdent un numéro de version contenant le mot « bepo ».

Pour installer les paquets, vous devez avoir les droits d'administrateur, et réaliser les étapes suivantes :

  • Ajouter dans le fichier /etc/apt/sources.list une des lignes suivantes (celle correspondant à votre distribution ; pour vérifier votre version de distribution, faire cat /etc/lsb-release) :

Debian :

deb http://download.tuxfamily.org/dvorak/debian etch main
deb http://download.tuxfamily.org/dvorak/debian lenny main
deb http://download.tuxfamily.org/dvorak/debian squeeze main
deb http://download.tuxfamily.org/dvorak/debian sid main

Ubuntu :

deb http://download.tuxfamily.org/dvorak/debian hardy main
deb http://download.tuxfamily.org/dvorak/debian intrepid main
deb http://download.tuxfamily.org/dvorak/debian jaunty main
deb http://download.tuxfamily.org/dvorak/debian karmic main
deb http://download.tuxfamily.org/dvorak/debian lucid main
deb http://download.tuxfamily.org/dvorak/debian maverick main
deb http://download.tuxfamily.org/dvorak/debian natty main
  • Chargez la clé ayant servi à signer les paquets avec la commande
wget http://download.tuxfamily.org/dvorak/debian/key.gpg -O- | sudo apt-key add -

Attention, cette clé a changé en mai 2010 : Si vous aviez déjà effectué cette commande, mais que vous obtenez maintenant un message indiquant qu'une clé publique se terminant par 624C8AB4 n'est pas disponible, veuillez refaire cette commande décrite précédemment, et effacer l'ancienne clé avec la commande :

sudo apt-key del AC50E3E3
  • Par défaut, le dépôt contenant le bépo n'est prioritaire que s'il contient une version des paquets plus récentes que celle fournis par Debian ou Ubuntu. Pour qu'une mise à jour ne puisse pas « effacer » le bépo, il faut donner au nouveau dépôt une priorité plus importante. Pour cela, il faut créer ou modifier le fichier /etc/apt/preferences pour y insérer le contenu suivant :
Package: xkb-data libx11-data console-data
Pin: origin download.tuxfamily.org
Pin-Priority: 1001
  • Mettez à jour votre liste de paquets disponibles et installez les paquets avec aptitude ou apt-get selon votre préférence :
sudo apt-get update
sudo apt-get install xkb-data libx11-data
sudo aptitude update
sudo aptitude install xkb-data libx11-data
  • Utiliser votre clavier en bépo
setxkbmap fr bepo
  • Repasser en clavier fr
setxkbmap fr